le LightShark de chez WorkPro

Posez ici vos questions concernant les lights et/ou postez vos idées éclairées...
Répondre
Mattdmon
NiouMember
NiouMember
Messages : 5
Enregistré le : 23 oct. 2020, 21:28

le LightShark de chez WorkPro

Message par Mattdmon » 27 oct. 2020, 16:37

Ziggy,

Encore une petite question.
Lorsque je crée mes effets, aucun soucis, je fais un cercle, la taille, ok; la vitesse, ok; mais l'offset, rien ne se passe.
D'apès ce que je comprends, il s'agit d'un délay entre les machines, c'est bien ça?
Mais, je ne comprends pas pourquoi il ne se passe rien lorsque je le crée.
Problème dans la config des lyres dans le soft? (range?) Il s'agit pourtant d'un fixture trouvé dans la bibliotheque Lightshark.
Je ne comprends pas.
Si tu as une idée ;-)
Merci.

Update : je viens de tester avec 2mac250 wash et l'offset ne décale pas mes machines (bug d'update firmware???)
Modifié en dernier par Mattdmon le 27 oct. 2020, 17:47, modifié 1 fois.

ericvda
Membre
Membre
Messages : 42
Enregistré le : 6 févr. 2018, 20:24

le LightShark de chez WorkPro

Message par ericvda » 27 oct. 2020, 16:55

Oui en effet Capture mange pas mal de ressources, et il faut une machine qui soit capable au niveau carte graphique d'aller comme il faut.

Ensuite si tu utilise Capture pour te faire une idée des ambiances et des rendus cela peut le faire. Mais si ta machine n'est pas assez puissante et que tu veux une idée precise des rendus comme le dis Ziggy cela sera moins evident.

https://www.capture.se

connectivités


Documentations

voila de quoi trouver des infos....
Console FLX - Projecteurs traditionnels et Leds - Lyre Automatique -

Pil71
NiouMember
NiouMember
Messages : 16
Enregistré le : 20 oct. 2020, 16:38

le LightShark de chez WorkPro

Message par Pil71 » 27 oct. 2020, 17:40

Une idée de référence de carte graphique qui me permettrait un rendu fluide et réaliste, en utilisant, bien sûr un bon processeur comme me l'a dit Ziggy ?
Merci

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 27 oct. 2020, 19:28

Mattdmon a écrit :
27 oct. 2020, 16:37
Lorsque je crée mes effets, aucun soucis, je fais un cercle, la taille, ok; la vitesse, ok; mais l'offset, rien ne se passe.....
Hello Matt; il est vrai que le moteur d'effets du Lightshark actuel est capricieux et "mal foutu"; mais l'équipe des développeurs en est conscient et ils sont en train d'en concevoir un nouveau moteur - je pense qu'on l'aura en fin d'année, sinon début l'année prochain.....ouffff, tous les utilisateurs l'attendent avec impatience ! mais j'ai eu confirmation qu'ils sont actuellement activement dessus !!
ça c'est pour la bonne nouvelle... (en même temps : depuis qu'ils ont commencé de bosser sur le nouveau moteur d'effets, ils ont complètement laissé de côté l'ancien et mis de côté les éventuels bugs et soucis...)

maintenant pour ta question : bien entendu "offset" avec une seule machine n'a pas de sens
de mémoire avec deux machines ça devrait déjà fonctionner, mais il semble que ça n'a jamais fonctionné pour le Lightshark
ensuite plusieurs machines (4, 5, 6 etc) là ça comment à faire du sens, et selon les version Firmware parfois ça marchait bien et parfois ça marchait moins bien....
mais on est bien d'accord qu'il ne faut pas appliquer le offset sur un groupe entier; mais plutôt un offset différent pour chaque appareil se trouvant dans le groupe; enfin la fonctionnalité FAN peut y aider pour aller plus vite !!
malheureusement je ne peux pas tester en ce moment car mon Lightshark est dans une salle pour toute cette semaine, où je suis en créa avec une Compagnie (et pas le temps de faire des tests etc)
donc reviens par ici dimanche ou lundi et je pourrai te dire avec exactitude ce qui fonctionne et ne fonctionne pas dans les effets et ce dernier Firmware

et pour répondre à Pil71 :
je ne suis vraiment pas un as de l'informatique.... et je ne pourrais pas te conseiller quoique ce soit en cartes-graphique (je n'y connais RIEN!!) mais j'espère qu'un autre copain/membre pourra te renseigner sur le sujet !! (mais je pense que tu devrais trouver aussi quelques pistes dans les documentation de L8 ou de Capture ou d'autres logiciels de "wysiwyg"

Mattdmon
NiouMember
NiouMember
Messages : 5
Enregistré le : 23 oct. 2020, 21:28

le LightShark de chez WorkPro

Message par Mattdmon » 27 oct. 2020, 19:58

Merci Ziggy,

Alors, j'avais testé avec 2 ministres led 60w (figure existant de le ls1), et ensuite, 2 mac250 wash et rien!

Donc, oui, vivement le nouveau moteur fx !

J'espère qu'il vont aussi intégrer un "positionneur x/y" pour déterminer le point d'origine de l'effet.

Bonne soirée 😀

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 27 oct. 2020, 21:08

Mattdmon a écrit :
27 oct. 2020, 19:58
....J'espère qu'il vont aussi intégrer un "positionneur x/y" pour déterminer le point d'origine de l'effet.
en fait les effets de positions jouent toujours autour d'une position de départ
moi perso, je me fais d'abord des palettes de position....
en rappelant telle ou telle palette de position l'effet va ensuite s'articuler autour de la position de départ !!

ericvda
Membre
Membre
Messages : 42
Enregistré le : 6 févr. 2018, 20:24

le LightShark de chez WorkPro

Message par ericvda » 28 oct. 2020, 18:27

C'est une bonne chose de savoir que Capture essaye de faire un peu mieux... Car en effet le but est quand même pas de devoir les dernières machines les plus puissances pour faire une émulation...
Donc j'attends avec impatience que les choses arrivent du coté de Capture...
Une bonne journée à tous

Eric
Console FLX - Projecteurs traditionnels et Leds - Lyre Automatique -

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 31 oct. 2020, 9:11

Mattdmon a écrit :
27 oct. 2020, 16:37
Lorsque je crée mes effets, aucun soucis, ....; mais l'offset, rien ne se passe.
Hello Matt
je viens de vérifier et le "OFFSET" fonctionne bien et il fait ce qu'on attend qu'il fasse.... à condition d'avoir au moins 3 appareils en sélection
donc avec deux appareils l'Offset ne fonctionne pas....!! (astuce : pour utiliser la fonction Offset avec seulement deux lyres, il suffit de patcher une troisième lyre (virtuelle et inexistante dans la réalité) mais qui forcera le Offset à décaler les mouvement entre les deux machines

Lareserve
Salut
Messages : 3
Enregistré le : 6 nov. 2020, 20:53

le LightShark de chez WorkPro

Message par Lareserve » 6 nov. 2020, 23:40

Bonjour à tous, Je n'ai pas trouvé de rubrique présentation donc désolé si je l'ai loupé...
Je suis actuellement en train de configurer une LS1 sur une installation fixe dans un bar et je rencontre quelques bugs ou bien mes manips sont mauvaises ( ce que je n'exclu pas).
Tout d abord voici ce que j ai sur mon installation :
20 servobeam2R Starway
10 StormliteHD Starway
10 Sniper 2R Elation
8 MovobeamZ150 Cameo
4 PckolorHD Starway
2 Dino Starway
4 lasers Evolite infinium 6600 RGB ( actuellement sur un Pangolin Beyond mais à terme je veux piloter le Beyond en DMX in )
2 BTVintage Britec
2 mini stage CO2 Sfat

Ca c est actuellement en place et j ai encore quelques trucs sympa qui devraient prochainement s'ajouter...

Mon premier probleme et sur l'édition d'un groupe de Fixture deja patché : Je souhaite par exemple de modifié la position par defaut de tous les servobeam ( par defaut PAN&TILT @128 ) et je voudrais les avoir à 080 et 000). J'ai beau modifier la valeur par défaut dans la librairie à chaque fois que je Clear ils reviennent à 128/128 ....
Une piste pour cela ?

Merci pour les infos et conseils qui seront les bienvenus.

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 7 nov. 2020, 9:08

Hello et bienvenu sur le Forum :)
alors tout d'abord, je le répète souvent : le LightShark est un excellent outil; mais pour en faire "un grand pupitre résolument pro", il lui manque encore pas mal de trucs et de fonctionnalités; même si l'évolution avance déjà à pas de géant.... (ne pas oublier non plus que les grands pupitres professionnels coûtent 5, 10 ou 30 fois plus cher !!
pour faire court, ce que tu veux faire n'est actuellement pas possible, mais sur la "to-do-liste" d'un future Firmware à venir...

au moment qu'une machine est patché, tous les datas du fixture-profile seront "transférés" et enregistré directement (et pour de bon) dans le Showfile et seront ensuite utilisé pour les mémoires, les Cues, les palettes etc; donc si on modifie le fixture-profile de la librairie "après-coup" (exemple les valeurs pour home, find ou defaut etc; ou les images de gobo etc etc etc) ces changements ne seront pas pris en compte par le Showfile, car lui, il contient déjà en fixe (et pour de bon !) l'ancien profil chargé lors du "patching" et utilisé désormais dans les mémoires (Cues Palettes etc)

pour que le nouveau profil soit pris en compte il faut donc recharger/repatcher le nouveau profil, ce qui veut dire pour Lightshark de d'abord effacer les "anciennes" machines .... car sinon il y aurait un gros conflits dans les mémoires déjà enregistrés entre l'ancien et le nouveau !

voici le concept de base qui est utilisé par les développeurs de consoles et logiciels en générale (donc chez certains "autres") pour faire ce que tu veux faire, c'est-à-dire : changer " à chaud" les valeurs par défaut ou home, highlight, lowlight ou autres datas consigné dans le profil de librairie)....
le concept le plus souvent utilisé (et c'est ce que WorkPro veut faire dans le future), c'est d'avoir la possibilité de remplacer dans le patch une machine par une autre qui a le même nombre de canaux et les mêmes propriétés d'attribut que l'ancienne; en clair : tu modifies d'abord ton profil; puis tu vas dans le patch et tu remplaces simplement l'ancienne machine par la nouvelle; et cela mettra aussi à jour les mémoires et palettes concernées par cette machine; on appelle cela couramment le "fixture-morphing" !

l'autre concept et fonctionnalité utilisé par certains concepteurs/fabricants, c'est que certaines valeur du "profil" (et notamment home, default, highlight, lowlight etc sont enregistré dans le Showfile comme un attribut et donc accessible et modifiable comme n'importe quel autre attribut.... (cela a aussi l'avantage de pouvoir changer ces valeurs machine par machine sans toucher aux réglages globaux !!)

malheureusement LightShark ne propose pour l'instant ni l'une ni l'autre de ces deux solution et la seule solution qui te reste c'est : effacer/dépatcher tes machines et repatcher les "nouvelles" machines aux profils modifiés !!
attention au piège du cache du showfile !! quand tu effaces et repatches en une seule opération cela va repatcher l'ancien profile qui continue à exister dans le cache interne du LightShark !!
l'opération à faire sera ceci:
-- dépatcher ce que tu veux changer (et éventuellement effacer les Cues qui l'utilisent actuellement)
-- enregistrer ce Showfile modifié avec son patch modifié et vidé
-- charger n'importe quel autre showfile (ceci videra le cache du LightShark)
-- recharger à nouveau l'autre Showfile d'avant et puis repatcher tes nouvelles machines avec le nouveau profil (qui sera maintenant à jour)

je sais que c'est un peu pénible mais actuellement le seul moyen pour arriver à ce que tu veux faire...
bonne chance (et n'hésite pas de poser des questions, ce sera avec plaisir si l'un de nous peut t'aider.... :) )

note aussi que tu as au choix deux comportements de CLEAR : Normal ou Default et ça se règle dans les "User-Preferences"

Lareserve
Salut
Messages : 3
Enregistré le : 6 nov. 2020, 20:53

le LightShark de chez WorkPro

Message par Lareserve » 7 nov. 2020, 9:41

Ok merci, Je vais donc creer un nouveau show, cela sera plus simple car actuellement je n ai rien fait d autre que patcher ( je n ai rien voulu encoder tant que je ne suis pas 100% satisfait de mes fixtures ..)

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 7 nov. 2020, 9:45

Lareserve a écrit :
7 nov. 2020, 9:41
....Je vais donc creer un nouveau show, cela sera plus simple car actuellement je n ai rien fait d autre que patcher ( je n ai rien voulu encoder tant que je ne suis pas 100% satisfait de mes fixtures ..)
c'est la meilleure chose à faire quand tu utilises des fixture-profiles personnalisés - j'en sais quelque-chose car j'ai beaucoup galéré avec ça au début (et changeant souvent de petits détails dans mes "fixtures-profiles" persos !!

Lareserve
Salut
Messages : 3
Enregistré le : 6 nov. 2020, 20:53

le LightShark de chez WorkPro

Message par Lareserve » 7 nov. 2020, 22:19

c'est la meilleure chose à faire quand tu utilises des fixture-profiles personnalisés - j'en sais quelque-chose car j'ai beaucoup galéré avec ça au début (et changeant souvent de petits détails dans mes "fixtures-profiles" persos !!
As tu trouvé un moyen de faire des courbes de dimmers personnalisé sur la console ? J aimerais transformer deux de mes circuits de gradateur en switch ( pour eviter qu'une fausse manip crame les electrovannes des canons CO2 ) et comme la fonction n 'est pas native sur mes grada. peut etre qu'en passant par une courbe de dimmer perso sur la console ça peut le faire ...

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 8 nov. 2020, 7:35

Hello Damien
non il n'y a pas de courbes virtuel de gradation dans le LightShark . Tu peux évidemment obtenir un résultat on/off en mettant un état "full" sur un bouton executor ou sur une palette; il faut biensûr utiliser un canal LTP pour qu'il ne soit pas affecté par le Grand-Master (ou un éventuel Playback Fader)
mais je te le conseille quand-même vivement !! le comportement de "switch" doit toujours être configuré dans le grada et onon pas dans le contrôleur ! car si ton grada ne le propose pas (et/ou qu'il n'est pas conçu pour) il y a de fortes chances que le triac ne fera jamais de switch on/off -> et qu'il gardera toujours un temps de monté et de descente propre; (ce qui pourrait bien endommager ton appareil !) donc prudence !

Avatar du membre
ziggy
Admin
Admin
Messages : 13962
Enregistré le : 2 févr. 2004, 21:09
Localisation : Lozère (48)
Contact :

le LightShark de chez WorkPro

Message par ziggy » 14 nov. 2020, 8:29

Hello
j'ai fini la traduction du mode d'emploi pour LS-1 et LS-Core pour WorkPro et ça devrait être bientôt dispo officiellement sur le site de WorkPro et de Freevox (mais au dernières nouvelles ils vont attendre que le prochain Firmware V_1.4 soit disponible, pour lancer un Package complet...)
en attendant qu'il soit officiellement diffusé vous pouvez me contactez par Mail ou MP si vous voulez l'avoir de suite !

et puis, je ne sais plus si je l'ai déjà dit ailleurs : la Team de WorkPro a conçu un petit logiciel utilitaire pour créer et éditer très rapidement un fichier de mapping-MIDI pour n'importe quel contrôleur, pour ceux qui ont un peu de mal avec le XML; ce petit logiciel est téléchargeable sur la page Support de leur site internet; il ne tourne que sur Windows

et puis voici quelques petits bugs mineurs dans la dernière version du Firmware (et concernant uniquement OSC et MIDI) :
pour OSC; le retour d'information via la fonction SYNC ne fonctionne plus depuis V_1.3.38 (fonctionnait bien avant);
l'encoder virtuel N°4 dans TouchOSC (et donc la commande OSC envoyé pour "encoder4" ne fonctionne plus
la commande OSC : TRIGGER-ROW ne fonctionne plus actuellement
les messages de commande MIDI pour le contrôle des encodeurs fonctionnent très mal (c'est du on/off au lieu d'un contrôle continu)
ils sont en train de réparer et ça remarchera dès la prochaine version du Firmware

Répondre